Flask 第三方插件导入方法

我遇到的问题
我在Flask运行是的问题就是,每次运行python manage.py runserver是都会显示一些警告信息,从提示可以看到只是警告信息,并不是错误信息。Google了以下原来是版本不同导致的兼容性问题,解决的办法就是使用新的导入方式即可。

旧的第三方插件导入方式

from flask.ext.sqlalchemy import SQLAlchemy

我们可以在ipython里查看第三方包的包名,按照包名导入即可。

评论

  • 还没有任何评论,来说两句吧。

  • 0%